Results 1 to 4 of 4

Thread: Cant see my dragon

  1. #1
    Member
    Join Date
    Mar 2017
    Location
    USW1 Server
    Posts
    55

    Cant see my dragon

    Curious what the issue is here... I can ride my mammoth and see it, but not my dragon. Dragon is invisible in my wardrobe panel, and also when I ride it. I am mounted in pic below. Its NOT my connection. I happened to catch this screen shot with the ping for you. Normally I'm between 50 and 90. I have uninstalled my storminstaller, and reinstalled. I've cleared cache.

    What is the issue?

    Thanks
    Skye - Raven Leader USW1
    DragonInvis.jpg

  2. #2
    We are aware of this issue, it's happened after new game update. Some models are became invisible with effects enabled. You can make it visible again, by clicking hide effects for appropriate model you have issues with (i.e. mounts / wings / relics). You will see the model, but without lights and so on. Really sorry for inconvenience, and we plan to fix it within this week.

  3. #3
    Member
    Join Date
    Mar 2017
    Location
    USW1 Server
    Posts
    55
    Thank you. It worked!

  4. #4
    We fixed issue with effects with today`s update, so you can enable it back again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
INFIPLAY - a company with considerable experience in the gaming world that is constantly evolving, bringing together friends in the playing field, allowing them to communicate and feel gaming heroes marching pace with the times, conquering new horizons of gaming space.